Problem with "Interpolate master kerning"

Post Reply
HugoJourdan
Posts: 11
Joined: 24 Jun 2021

Problem with "Interpolate master kerning"

Post by HugoJourdan »

Hi Tim,

I'm working on a font project with 5 width in the same file and each width have 3 masters. (so I have a total of 15 masters). I have set models only for extreme weight of each width and tried to use "Interpolate master kerning" for regular masters.

So I have a set up like this :
- Compressed Thin [Models set]
- Compressed Regular [Interpolate master kerning]
- Compressed Black [Models set]
- Condensed Thin [Models set]
- Condensed Regular [Interpolate master kerning]
- Condensed Black [Models set]
etc...

But value interpolated with "Interpolate master kerning" are not correct.
I think KernOn doesn't detect correctly which source masters has to be select for each master set on "Interpolate master kerning".

I tried to keep only one width and run KernOn again, and this time master with "Interpolate master kerning", has been correctly interpolated.

Maybe it could be nice for master set on "Interpolate master kerning", to be able to indicate to KernOn which masters to select as interpolation source. Something like in the plugin "Kernkraft" by Mark Frömberg.
HugoJourdan
Posts: 11
Joined: 24 Jun 2021

Re: Problem with "Interpolate master kerning"

Post by HugoJourdan »

I think I have a bit information about the cause of the problem.
When I enable and disable "Interpolate master Kerning", I found that KernOn create interpolated model pairs. But sometime some of these pairs are too tight or too loose for the master and KernOn switch them to Independent pairs.

It's seem that if this happen, "Interpolate master Kerning" not work correctly.
User avatar
Tim Ahrens
Site Admin
Posts: 264
Joined: 11 Jul 2019

Re: Problem with "Interpolate master kerning"

Post by Tim Ahrens »

Sorry about the late reply. Would you mind sending me the file?

Kern On uses the same interpolation coefficients as Glyphs. Can you try using “Re-interpolate” from the layers palette on the Compressed Regular master? Does it look roughly the same in terms of weight and width (except for corrections)?

Similarly, you could set up an instance (aka export) identical to the Compressed Regular master, and then disable the Compressed Regular using a custom parameter. That way, you will see an interpolated version. If it doesn’t look similar to the real Compressed Regular master then the master co-ordinates are not set correctly.
Post Reply