Kern On sleeps in second master

Post Reply
User avatar
SCarewe
Posts: 31
Joined: 23 Apr 2021

Kern On sleeps in second master

Post by SCarewe »

Hello, I have run into an issue with KO while working on an italic. I set up the first (Light) master with KO, but when I switched to the other, Black, master, I found that KO simply doesn't run at all. It doesn't turn on auto-pairs for anything and I also can't define any autopairs, let alone models. I restarted both Glyphs and KO multiple times. What could the issue be? Many thanks!
Attachments
2021-06-15 19.31.59.jpg
2021-06-15 19.31.59.jpg (26.31 KiB) Viewed 482 times
User avatar
Tim Ahrens
Site Admin
Posts: 164
Joined: 11 Jul 2019

Re: Kern On sleeps in second master

Post by Tim Ahrens »

Thanks for reporting this. I can reproduce the problem, looks like this is simply a use case that was never tested so the bug went unnoticed.

I will fix this as soon as possible.
User avatar
SCarewe
Posts: 31
Joined: 23 Apr 2021

Re: Kern On sleeps in second master

Post by SCarewe »

Thanks for letting me know! Anything I can do in the meantime to get this running again? How were you able to reproduce this? What is the specific use case that I ran into?
User avatar
Tim Ahrens
Site Admin
Posts: 164
Joined: 11 Jul 2019

Re: Kern On sleeps in second master

Post by Tim Ahrens »

Sorry, I realized I cannot really reproduce the problem. If a master is completely new it’s normal not to have any models (of course), and no auto-pairs. It is, in a way, sleeping.

However, you should be able to set new models, and after that, there should be auto-pairs as well.

Would you mind sending me the font? Thanks!
User avatar
SCarewe
Posts: 31
Joined: 23 Apr 2021

Re: Kern On sleeps in second master

Post by SCarewe »

It appears I misrepresented my case. The master is not new, the italic file is more than a year old and I was simply re-doing the kerning with KO, starting with the Light master. But, when I switched to the Black, it simply didn't work. I will send you the file shortly. Thanks!
User avatar
SCarewe
Posts: 31
Joined: 23 Apr 2021

Re: Kern On sleeps in second master

Post by SCarewe »

Okay, apologies. I am able to set models by typing in a number for a pair, which KO immediately recognises as a model. Then, the rest of the pairs suddenly jump to auto. So it appears KO is simply not initialised for the master yet, but it becomes initialised as soon as I set a model like this. Still not quite the desired behaviour, but at least not as detrimental. Sorry!
User avatar
Tim Ahrens
Site Admin
Posts: 164
Joined: 11 Jul 2019

Re: Kern On sleeps in second master

Post by Tim Ahrens »

On the other hand, a proper feedback message (that simply explains that the master does not have any models yet) wouldn’t hurt, you are right.
Post Reply